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1 Class Overview

This training manual is designed to act as a guide for government and public users who use the reporting features within the Federal Procurement Data System – Next Generation (FPDS-NG).  This training manual is used in conjunction with the Reporting Class.  In addition to this training manual, further instruction is available via the following online tools:

· User Guide

· Help System

· Computer Based Training (CBT)

1.1 Document Conventions

This guide uses the following formatting conventions:

Table 1‑1 Document Conventions
	If You See…
	It Means…

	italicized text
	The word or set of words are especially emphasized

	boldfaced text
	Emphasized subjects

	Note:
	The following paragraph provides additional facts.

	Tip:
	The following paragraph provides suggested uses.

	Warning:
	The following paragraph notes situations where you can overwrite or corrupt data, unless you follow the specified procedure.

	monospaced text
	This is a code example.

	bold monospaced text
	This is an operating system command you enter from a prompt to execute a task.


1.2 Training Manual Structure 

This training manual provides how-to guides, exercises, and examples that describe FPDS-NG Reporting functions and processes.  As such, the training manual is a valuable resource tool for authorized government and public users.  Class participants are encouraged to use this training manual at their respective work locations as a reference and training tool for in-house use.  The following table describes the training manual layout and design.

Table 1‑2 Training Manual Structure
	Manual Section
	Section Purpose

	Overview 
	Defines and explains the importance of each section.

	How To 
	Provides answers to frequently asked questions with simple, easy to follow instructions.

	Examples
	Illustrates specific functions to provide understanding for section tasks

	Exercises 
	Exercises are used as a tool for class participants to gain hands-on experience.  The course exercises are discussed in class to measure and reinforce the participant’s comprehension.

	Review
	Summarizes topics that allow participants to work independently and provides feedback that is used as a performance measurement for training.


2 Common System Features

2.1 Login Screen 

Agency System Administrators create user IDs and passwords for their respective agency.  Public FPDS-NG users are provided access to Awards, System Administration, and Report features associated with the system privileges and user types assigned.  The user accesses an initial login screen and enters a user ID and password.

Note: Agency and Non-Agency personnel that will not be entering data in FPDS-NG may not have an Agency System Administrator.  Under these circumstances you will create your own User ID and Password by registering under the registration section located on the lower left corner of the Login screen. 

2.2 Initial Login Screen

The Login screen, shown in the following figure, is the initial screen provided for FPDS-NG users. To log into FPDS-NG, the user enters their user ID, password, and then select [image: image2.png]


. A successful login opens the Navigation screen shown below..

Figure 2‑1 Initial Login Screen
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2.3 Incorrect Logins

If the user enters an incorrect password, the FPDS-NG Login screen allows the user three attempts to enter the correct password. 

2.4 Forgotten Password Function

If the user has forgotten his/her password, the password can be recovered by following the [image: image4.png]ZAFPDS Log
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 link. This displays the screen shown in the following figure. The user enters his/her user ID, and then select[image: image5.png]\G Forgot Password - Microsoft Internet Explorer
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.  Once the user ID has been submitted, the Forgotten Password feature will email the user a new login password.

Figure 2‑2 Forgotten Password Notification Screen
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2.5 Expired Login Session

After a period of inactivity, approximately 60 minutes, FPDS-NG will automatically end the user’s session. If the user needs to restart the session, a second login screen is provided.  This is the Expired Login screen which is illustrated in the following figure.  The user must re-enter his/her user name and password, and then select[image: image7.png]


.  On a successful login, FPDS-NG opens to the Navigation screen shown in the following section.

Figure 2‑3 Expired Login Screen
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2.6 Navigation Screen
The FPDS-NG Navigation screen shown in the following figure is organized in five sections: Awards, Basic IDVs, Transactions/Modifications, System Administration, and Reports.  Each section contains a list of tasks related to the section. Each task, links to a specific Web-based form on which users enter and submit data with the exception of the Reports section.  The Reports section retrieves and displays Federal Procurement data stored in the FPDS-NG database.
Figure 2‑4 Navigation Screen
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2.7 Web Form Toolbar

Search functions are available throughout FPDS-NG. These functions are used to access documents, organizations, service classifications, vendor information, etc. A standard toolbar, similar to the one depicted in the following figure, is available for each Web form. For example, the toolbar displayed below is located at the bottom of the Advanced Search screen.

Figure 2‑5 Advanced Search Standard Toolbar 
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The toolbar shown in the following figure is accessible on the right side of all selection screens (i.e., Vendor, Contracting Office ID, and Service Classifications selection screens.)

Figure 2‑6 Standard Toolbar for Selection Screens 
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2.8 Search Function 

One feature common to most Web forms in FPDS-NG is the Search function. For example, to search for vendors in the Web forms, select [image: image12.png]


 located on the Advanced Search Screen shown in the following figure. 

Figure 2‑7 Advanced Search Ellipses Button
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The Vendor Selection Screen displays.

Figure 2‑8 Vendor Selection Screen Criteria
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To find a vendor by name, type in part or all of the vendor’s name and use the search function to locate a list of Vendors, as shown in the following figure. The Search function is available for all users.

Figure 2‑9 Vendor Selection Screen with Search Results
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Using the Search Function
1) From the Navigation screen, select [image: image16.png]Advanced Search



 located at the top middle section of the screen.

2) To search for a vendor select [image: image17.png]


 next to the Vendor Name field.

3) The Vendor Selection screen is displayed.

4) Type in all or part of the vendor’s name and select [image: image18.png]


 located at the right lower corner of the screen. 

5) The User Selection screen displays with a Vendor list.

Create a New Search

6) To clear the search criteria and enter new Vendor information select [image: image19.png]Clear



 on the bottom right corner of the screen. The fields are now blank as shown in the following figure.

Figure 2‑10 Vendor Selection Screen
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7) In the DUNS Number field, located in the lower left corner of the screen, type in a Vendor DUNS Number.  Select [image: image21.png]


 located in the lower right corner of the screen

8) Information based on the search criteria provides a list of Vendors which are displayed.

Figure 2‑11 Vendor Selection Defined
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9) To select the appropriate Vendor, select the radio button [image: image23.png]


 located in the left upper corner of the screen.  

10) After selecting the radio button next to the Vendor, click [image: image24.png]Select



 located in the right top corner, to place the Vendor information in the Advanced Search Screen.

Notes: 

Fewer search criteria will produce more results, however, to search the list of vendors without using a criteria selection, leave all fields blank in the bottom of the screen, and select [image: image25.png]


. 

When the matching criteria fields are empty, the generated list contains a larger selection of vendors. Due to the volume of data in FPDS-NG, the selection results are limited to a portion of the data available, such as the first 200 records. It is recommended that you always enter search criteria to narrow the selection when possible.
2.9 PIID Use in Advanced Search 

When performing an advanced search, a Procurement Instrument Identifier number (PIID) can be used to quickly access a contract. The PIID field can be found on the Advanced Search screen as shown in the following figure. Entering the Agency ID, PIID number, and selecting the Status for the contract will display the contract with a link to allow access to the contract. 

Figure 2‑12 Advanced Search Screen
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2.10 Migrated PIIDs

For migrated IDVs, the PIID is the same as the original contract number. For migrated awards, the PIID is a combination of the following:

· Contracting Office Code
· Action Date (format "YYYYMM")
· Contract Action Type (A, B, C, D)
· Order Number (if it exists)
· Contract Number
The formula used for the PIID number can be used to perform an advanced search. For example, to find a Delivery Order created in October 1995 with:

· Agency – U.S. Coast Guard (6950) 
· Contracting Office – 23

· Order Number – DTCG2394FTACX01

· Contract Number – DTCG2391DTTMB12

The PIID is calculated by the following:

· "00023" (Contracting Office ID with leading zeroes)

· +"199510" (Action Date in YYYYMM format)

· +"C" (Contract Action type - Delivery Order)

· +"DTCG2394FTACX01" (Order Number)

· +"DTCG2391DTTMB12" (Contract Number)

The PIID would equal 00023199510CDTCG2394FTACX01DTCG2391DTTMB12.

Notes: 

The PIID Number format must be uppercase, alphanumeric with no embedded spaces or special characters.  FPDS-NG will convert lowercase letters to uppercase, remove leading or trailing blank spaces, and remove any non-alphanumeric characters prior to validation.

The Contract Action type is a single character representing the award type.

2.11 Contract Search Results

The Advanced search generates a list of documents that match the search criteria entered on the screen.  The list is displayed with links to matching contracts on the Contract Search results screen shown in the following figure. The search results screen displays a list of ten contracts out of the number of contracts found.  Selecting the link [image: image27.png]


 located in the right top corner of the screen displays the next ten contacts on the screen. 

Figure 2‑13 Contract Search Results Screen
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To access a contract select the link [image: image29.png][197811C56GS02T00809




 of the contract you wish to open. 

Figure 2‑14 Delivery Task Order
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3 Introduction to Reports

The Reports document describes the standard and customized reporting capability in FPDS-NG. Both the public and government reporting functionality is explained. The Report features are divided into sections including the required steps for generating reports. A description of the reports is provided which includes the following: 

· Description of what the report displays

· Mandatory/optional criteria for the report

· Fields/data displayed on the report

· Primary sort criteria used in the report

· Secondary sort criteria used in the report

· Search criteria available for the report

3.1 Standard Report List

The following table displays a list of reports provided in FPDS-NG by their report grouping category. These standard report formats are designed to anticipate the needs of government and public users. These reports provide quick accessibility to information needed on a regular basis. The selection of reports available in FPDS-NG gathers information on procurement events from the Event Log and holds this information in a database for analysis and reporting.

Table 3‑1 Report Names

	Report Name / Report Category

	Who (Who is winning government contracts by vendor name or type?)

	Awards by Contractor Type

	Contractor Search Report 

	What (What types of products and services the government has been buying?)

	Total Actions by PSC   

	Total Actions by NAICS    

	Procurement History for Market Research

	Federal Contract Actions & Dollars

	Contract Detail

	Where (Where is the government spending its money, both in the US and abroad?)

	Geographic Reports by Place of Performance

	Geographic Report by Vendor Location

	When (When were the procurements made?)

	Procurement History for Market Research Report  

	Contract Detail

	How (How did the government make the award (small business, type of competition, purchase card, etc.)? How is the government meeting its statutory goals?)

	Performance Based Service Acquisition    

	Bundling & Consolidated contracts greater than or equal to 5M

	Recycled Content Product Purchasing Data    

	Small Business Goaling    

	SB Competitiveness Demonstration Program    

	Competition Report    

	Funding Report    

	SB Achievements by Awarding Organization

	Purchase Card as Payment Method Report

	Official SB Goaling Report for FY 2005 & 2006

	System Administrator

	Contracting Office Report

	Individual Data Item Oversight Tracker    

	List of Users    

	National Interest Action   

	Status of Actions

	Workload Report


4 Reports Format
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The Report functions are accessed via the Navigation screen shown in the following figure. FPDS-NG reporting allows the Federal Government to track users, performance, and contract statistics. FPDS-NG gathers information on reported procurement transactions and stores this information in a database for analysis and reporting. The reports are generated using two types of functionality:

· Standard Format (Canned Reports)

· Customized Format (Query Panel)

Figure 4‑1 FPDS-NG Navigation Screen
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The following sections provide instruction for accessing and generating reports in FPDS-NG. Public and government users have similar procedures for accessing reports. Both procedures are provided in this manual. To access the reports in FPDS-NG, you must be a registered government or public user in FPDS-NG. The following instructions can be used based on the designation of the user (public or government). Some reports are not accessible for the public user.

5 Standard Reports (My Favorites)
[image: image212.png]


The My Favorites Reports module is used to acquire and store selected reports for a defined period of time. FPDS-NG reports are generated using the data agencies submit in the Awards and IDVs sections. The selection of reports is determined by the user’s profile. There are two profile user types; public and government. These profiles are created under System Administration in the user account section. The Reports provide information for analyzing performance, contract, statistics, and user data from the FPDS-NG database.

The Standard Reports screen, shown in the following figure, stores a list of selected reports in the view-list. The different types of reports are listed below. 

· Published reports (e.g. FPR, etc)

· Reference table queries (e.g. NAICS, PSC, etc)

· Selected reports

· Saved selection criteria for each report

The Standard Reports screen references the user’s profile to display selected reports. The first time the screen is initially opened there are no reports to display. Reports must first be selected from any of the report catagories in order to store and view them in the My Favorites screen.

Figure 5‑1 My Favorites Screen
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6 Available Reports

The My Favorites screen shown in the following figure is broken down into categories for the various types of reports and information offered in FPDS-NG.  Those categories are:  Favorites, Who, What, Where When, How Ad Hoc, and  System Administration reports, as well as  Help, Submit Comments, and Switch to the Classic (Original) View.  Each report category includes a “bookmark” icon  [image: image33.bmp] which will add the specific report to the Favorites category, and a “preview” icon [image: image34.bmp], which allows the user to look at the report with out executing it. Reports in the Favorites category includes a “delete” icon [image: image35.bmp],  which enables the user to delete the report from the Favorites category.  The search criteria screen is automatically brought up when the user chooses to execute a report. . If you wish to return to the “My Reports” view click on the Classic View button [image: image36.png]



If you are a new user the Favorites section will initially be blank until reports are added to the section. If you are a current user any reports that are in the “My Reports” section will automatically appear. Additionally you can execute a report from any of the report categories by clicking on one of the Reports buttons and then clicking on the selected report link.
Figure 6‑1 My Favorites Screen
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6.1 View Reports 

Users may view reports before adding them to the My Favorites screen by selecting the preview icon [image: image38.jpg]P T SRR TS BE
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 located in front of each report. The report format is displayed as shown in the following figure.

Figure 6‑2 Report Preview
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6.2 My Favorites Screen 

Once reports are selected from the various Reports Buttons the user is able to generate a report from the My Favorites screen shown in the following figure.

Figure 6‑3 My Favorites Screen
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Exercise – Login to FPDS-NG and Access My Favorites
The following steps are provided to assist government users in logging into FPDS-NG and accessing standard reports.

1) Go to the URL provided by the instructor.

2) Log in to FPDS-NG with the user ID and password provided by the instructor.

Opening the Standard Reports Screen

The Standard Reports screen, shown in Figure 6‑3, displays a list of selected reports associated with the user’s profile. To access the Standard Reports list use the following steps.

1) To open the Standard Reports screen from the Main Navigation screen select   [image: image41.png]


.

2) FPDS-NG will display the Standard Reports screen shown in the following figure.

Figure 6‑4 My Favorites Screen
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Selecting Available Reports 

Reports must be added to the My Favorites screen to generate or print reports. To add reports to the My Favorites screen, use the following steps.

1) Click on one of the six Report category buttons
Figure 6-5 Report Buttons
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2) Click on the Add to Favorites icon[image: image49.bmp] next to the specific report you want to add
Figure 6-6 Who Reports Screen
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3) The report along with any search criteria will be added to the Favorites category

4) You can then execute the report from either the Favorites category or the Report category by clicking on the report name.

6.3 Report Categories
[image: image51.png]


 Favorite Reports are defined by the user and consist of a collection of reports that have been specifically chosen.  This section will be blank, if you are a new user,  until the user bookmarks reports to be added to the Favorites section.  Otherwise the Favorites category will be populated with the reports that currently exist in “My Reports”.
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 Who Reports are defined as:

Who is winning government contracts by vendor name or type?

The reports in this section include:


Contractor Search Report


Awards by Contractor Type
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 What Reports are defined as:

What types of products and services the government has been buying?

The reports in this section include:


Total Actions by PSC


Total Actions by NAICS


Procurement History for Market Research


Federal Contract Actions &  Dollars


Contract Detail
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 Where Reports are defined as:

Where is the government spending its money, both in the US and abroad?

The reports in this section include:


Geographic Reports by Place of Performance


Geographic Report by Vendor Location
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 When Reports are defined as:

When were the procurements made?

The reports in this section include:


Procurement History for Market Research Report


Contract Detail

[image: image56.png]


 How Reports are defined as

How did the government make the award (small business, type of competition, purchase card, etc.)? How is the government meeting its statutory goals? 

The Reports in this section include:


Performance Based Service Acquisition


Bundling & Consolidated contracts greater than or equal to 5M


Recycled Content Product Purchasing Data


Small Business Goaling


SB Competitiveness Demonstration Program


Competition Report


Funding Report


SB Achievements by Awarding Organization 


Purchase Card as Payment Method Report


Official SB Goaling Report for FY 2005 & 2006

[image: image57.png]


 Ad Hoc Reports  are defined as:

Custom reports created by the user.  This section will be blank until the user creates a custom Ad Hoc report.
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 System Administrator Reports

The reports in this section include:

Contracting Office Report


Individual Data Item Oversight Tracker


List of Users


National Interest Action


Status of Actions


Workload
6.4 Search Name 

The Search name shown in the following figure is displayed with the name “Default.” This field is used to name the search criteria entered for a selected report. Saving the search criteria with a designated name stores the information on the My Favorites Screen under the original link for the report. The saved search criterion is associated with the users login ID. The user can retrieve this information by selecting the saved name in the My Favorites screen. This function saves key strokes by eliminating the process of entering repeated search information for recurring reports.

6.5 Search Criteria Features

Search criteria screens are used to run all reports. After clicking on a report, the search criteria screen is displayed. The user enters the data in this screen that determines the data displayed in the report. 

Figure 6‑5 Search Criteria Screen
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As with other screens in FPDS-NG, the fields labeled with lookup [image: image60.png]


 buttons can be auto-filled by selecting the [image: image61.png]


 button and using the associated Search/Select screen as shown in the following figure.

Figure 6‑6 Search/Select Option
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6.6 Search Criteria Tools

Wildcard

The % is the wildcard character that may be used in the data entry fields. Enter a wildcard after entering the first part of the data string. For example, when a user enters “COM%” in a data field, the search will return anything that starts with “COM”, for example, company, complete, and composition.

Saving Report Criteria for Multiple Report Runs

The Criteria Name field allows the user to save the report criteria so that it can be executed again without having to enter all of the data. The user may save as many different criteria for a report as they wish. The name of the criteria is displayed on the My Favorites screen below the associated report. 

6.7 Search Criteria Label Conventions

Government Wide

All reports are generated Government Wide. The drill down feature accesses detailed levels of data in the system to further filter information provided on the standard reports.

Department

The Department label is a drill down feature that specifies the department or agency you are selecting. For example, GSA or DoD. 

Agency Code

The Agency label is a drill down feature that specifies the organization or service under the department. An example would be, the Federal Supply Service of GSA or Navy of DoD.

criteria screens have features that are consistent regardless of the data the user is asked to enter. 

6.8 Field Types
Mandatory Fields

Fields in the search criteria that are orange with an asterisk (*) are mandatory and must have a value. A value must be entered before the report will execute. An error message is displayed when no data is entered in a mandatory field.

Non-mandatory Fields

Fields in the search criteria that do not have an asterisk (*) are not required and may be left blank. When left blank, all values for that field are shown in the report.

6.9 Search Criteria Screen Actions/Buttons

[image: image63.png]


 The execute button runs the report based on the criteria entered in the search criteria screen. If mandatory fields are not filled in, an error message is displayed. 

[image: image64.png]


 The save button saves the search criteria with the name shown in the ‘Criteria Name’ field. The saved search is then placed below the report name on the My Favorites screen. 

[image: image65.png]Clear



 The clear button removes any information placed in the search fields by the user and displays the system generated default search criteria.

[image: image66.png]( Cancel )



 The cancel button closes the search criteria screen. The report is not executed and the search criteria are not saved.

Exercise - Saving Report Search Criteria

The Search Criteria screen provides the user the ability to name and save information entered for reports that are frequently repeated.  

To save a report with specific search criteria information open the Standard Reports screen using the following steps.

1)  To open the Standard Reports screen from the Main Navigation screen select   [image: image67.png]


.

2) My Favorites Report screen is displayed with a catalog of reports that have been selected or for first time users this screen is initially blank.

3) Select a report to add .by clicking on one of the Report Buttons
4) Click on the Add to Favorites icon[image: image68.bmp] next to the specific report you want to add
5) Click on [image: image69.png]


 to see the report link displayed in this screen.

6) Select the link for the report that will be saved with specific search criteria information.

7) The search criteria screen is displayed with “Default” entered in the Search Name field.

8)  Enter a name or description in the Search Name field.

9) Enter the From and To dates or associated criteria for the selected report.
10) Select[image: image70.png]


 located at the bottom of the screen.

11) The Search Criteria screen will display the message The Search Criteria was saved successfully.

12) Select [image: image71.png]¢ Cancel )




13) The saved name or description is listed in the My Favorites screen located under the original report link. 

Generating Reports

The My Favorites screen provides a list of selected reports the users can generate, print, or rename for future use. 

1) Select the link for the report that will be generated.

2) Enter the search criteria for the chosen report and select[image: image72.png]Execute )



.

3) The report is displayed using the search criteria.
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7 Using FPDS-NG Reports

FPDS-NG produces reports automatically by querying the FPDS-NG database and creating a report based on your search criteria. This section covers the following general use concepts:

· Report Actions

· Search Criteria Features

· Public User Procedures for Reports

· Government User Procedures for Reports

· Summary Reports

7.1 Report Actions
Export

The export functionality provides the ability to save the data as an HTML file, Microsoft Excel pivot table, a PDF, or a command delimited file (CSV).

Email

The send functionality provides the ability to send the report in an email. The user enters the email addresses for the desired recipients and the report is sent by the system.

Close

The close functionality closes the report screen.

Printing a Report

To view the reports in its entirety use the scroll down. When printing a report, only the data for the section displayed is printed. If you want to print the entire report, download the report to HTML, PDF, or CSV format and print. 

Exercise - Exporting or Sending Reports

The export and email feature is used to save a report using a file format that provides the ability to email, save for review, or open in a spreadsheet. The following four formats are provided for exporting and emailing reports: Microsoft Excel, HTML, PDF, and CSV (comma separated value).

1) Select the link for the report that will be downloaded.

2) Enter the search criteria information; if the selected link is saved search criteria skip this step.

3) Select [image: image74.png]Execute )



 to generate the report.

4) Select [image: image75.png]


 to open the export report window or [image: image76.png]


 for Business Objects reports.
5) To export a report, use the preferred format by selecting one of the options shown in the following figure.

Figure 7‑1 Export Window
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6) For Business Object reports chose from the following:
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7) To open and save the report in the selected format select [image: image79.png]Export




 and then save.

Or

8) To email a report, after executing the report (step 3 above), select [image: image80.png]Send



. 

9) After selecting the email option the email report window shown in the following figure will display.

Figure 7‑2 Email Window
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10) Enter the email address and select the format from the drop down window to email this report.

11) Select [image: image82.png]Send




 to email the report.

Or
For Business Objects reports

1) To email a report, after executing the report select [image: image83.png]



2) After selecting the email option the email report window shown in the following figure will display.
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3) Enter the email address and select the format by clicking on the radio button.

4) Select [image: image85.png]Senc



 to email the report.
8 FPDS-NG Adhoc Reporting Tool

8.1 Introduction
This section specifies instructions for creating reports based on your selected criteria. Agencies/Companies can create reports that answer their business questions and analyze processes. FPDS-NG uses the Informatica, Power Analyzer tool to create custom reports. Ad hoc reporting is a user friendly feature designed for all levels of users. Custom reports are created using queries. A query is one or more statements that request data from a database. If the data is available, then the requested data returns in the form of a table which contains rows and columns. Queries are sent to the databases in a language called SQL. However, when using the Report Panel, SQL knowledge is not required. Users have the option to save customized queries and reports on a User ID specific Adhoc Screen.

Figure 8‑1 FPDS-NG Navigation Screen
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Note: Government users who wish to obtain reports must register with FPDS-NG regardless of whether or not they will be entering data into the system.

8.2 Ad Hoc Reporting Basics

The Ad Hoc reporting tool provides features designed to make business analytics simple and easily accessible to all users. When creating queries all of the Ad Hoc features do not have to be used to access information needed to run a report. Users can customize a dashboard to directly access key reports and documents from one place. A number of analytic tasks can be completed when a report is viewed.

· Analyze reported procurement within the Government.

· Prepare reports in ways that look at specific business questions

· Build reports to analyze business processes, such as, spending performance for agencies.

Informatica has an analytics engine that extracts, filters, and presents information in easy to understand reports. It uses a web browser interface to design, develop, and deploy enterprise analytic reports. It also works with a database repository to keep track of information about a user’s enterprise metrics, reports, and report delivery.

8.3 Tasks
Users can perform analytic tasks based on their roles and privileges. When the system administrator sets up a user account in FPDS-NG, the system administrator assigns a role and privileges. 

The following tasks are available to quickly access analytical data:

· Find and view any report in your personal folder.

· Export PowerAnalyzer data to Excel and other formats.

· Easily make changes to existing reports to explore more details and gain further insight into different aspects of the business processes.

· Perform complex analytics by setting up reports that logically link to other reports in an analytic workflow.

· Set up metrics and attributes used to create reports.

8.4 Terms
This section discusses some key terms that the Ad Hoc Reporting tool uses.

· Metrics

· Attributes

Metrics and attributes are central to the analytics process. Any analysis of a business process involves measurements of its performance. In the Ad Hoc reporting tool, a measurement is recognized as a metric. Metrics are the factors used to evaluate a business process. For example, a procurement executive might say that she needs to analyze “the average dollars obligated to small businesses in Virginia for the previous physical year by quarters.” In this case, the measurement, or metric, that the procurement executive wants to evaluate is the average dollars obligated. 

The parameters involved in a metric are called dimension attributes or attributes. In the previous example, the attributes that affect the metric are awards (Dollars Obligated), Place of Performance (Virginia), and time (last fiscal year).  Attributes are the factors that determine the value of the metric. The user creates a report based on the available metrics and attributes. When a report is viewed, custom metrics can also be created specific to the report.

In a simple report, where there is one attribute and one metric, attributes are the rows in the left column and metrics are values in the right column. Metrics are always numeric values. The following figure shows a sample of a simple Ad Hoc report and the location of the metrics and attributes:

Figure 8‑2 Metric and Attribute
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In a complex report with more than one attribute and more than one metric, multiple columns of attributes and metrics display. In some cases, there can be multiple columns of the same metric for different attributes.

The following figure shows a sample of a complex report and the location of the metrics and attributes:

Figure 8‑3 Complex Report and Metric and Attribute Location
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8.5 PowerAnalyzer Reports

Adhoc reports display enterprise data as metrics and attributes. When a report is opened it is displayed on the Analyze tab. 

The report table displays the report data in a tabular form. The report chart displays the report data as a chart. The Analyze tab also displays report metadata. The Reporting section uses the term report metadata for the following objects associated with a report:

· Filters - A filter displays report data based on certain conditions.

· Highlighting - Highlighting draws attention to critical data in a report and helps pinpoint problem areas.

Certain buttons and icons associated with the report provide additional information about the report. These icons and buttons display at the top of the reports.

Table 8‑1 Buttons and Icons
	Button/Icon
	Name
	Description
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	Permission Button
	This feature allows the user to view and set access permissions. To view or access permissions, you must be the owner of the report or you must have the following privilege and permission:

· Manage Public Directory privilege

· Change Permission
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	Ownership icon
	This feature indicates if you are the owner of the report. If you are the person that created and saved the report (report owner), the ownership icon is red. If you move the cursor over the ownership icon, the report owner ID displays.


8.6 Ad Hoc Reports and Table Layouts

The report table presents the report data as rows and columns in a table. There are three types of report tables:

· Tabular - A tabular report table contains row headers only. 

· Cross tabular - A cross tabular report table contains row and column headers. 

· Sectional - A sectional report table displays the report data as sections. Each section of the report table provides the data for a unique attribute value. 

In the PowerAnalyzer reports, a metric value is also called an “item” in the report table. 

· To select a metric value, click in the report table. 

· To select a contiguous range of values, Shift-click.

· To select a non-contiguous range of values, Ctrl-click.

· In a cross tabular report table, if all the row or column attributes are selected, all the metric values are selected in the report.

8.7 Ad Hoc Reports

Ad Hoc reports can be created using prompts. When viewing an Ad Hoc report the user is prompted to select the components for the reports. This allows limits to be placed on the contents of the report by displaying only the data wanted. Prompts for reports can be created based on the following report components:

· Metrics 

· Attributes 

· Attribute and metric filters 

9 Reporting Tabs
[image: image213.png]


Selecting Ad Hoc will display the query panel and tabs. The Ad Hoc Reporting Screen contains personal settings applied by the user. The first time the query panel is accessed by the user, the reporting screen will display without information or settings shown in the following figure. 

Figure 9‑1 Ad Hoc Reporting Screen
[image: image91.jpg]



9.1  Find Button
The Find button allows the user to search for reports and shared documents that they want to view. The Ad Hoc reporting tool keeps all reports in the Personal Folder of each user. To find reports, browse through the Personal Folders. The user can also search for a specific report. While browsing the folder the user can organize reports by creating new folders and moving reports to these new folders.

Figure 9‑2 Find Tab
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9.2 New Button
The New button allows you to create analytic reports from the FPDS-NG data. A report consists of a set of related metrics and attributes. When you create a report, one or more SQL queries are created. The queries are based on metrics, attributes, filters, and rankings you specify in the report. When you run a report, Ad Hoc runs the queries and displays the data returned from the database. You can modify the data and format of a report. 

Figure 9‑3. New Tab
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Creating Reports

1) The first step in creating reports is specifying the data and the format for the report. 

2) To create a report select [image: image94.png]


.

3) Depending on the data that will be displayed in a report, one or more of the following steps will be completed:

· Select metrics for the report

· Select attributes for the report

· Set filters for the report 

· Set Layout and Format for the report

To create reports, the user must have the Reporting Tools privilege. When the report displays, it opens in the Analyze tab. While the report is displayed, use the Edit Report button to return to the report. Do not click the browser Back button or the Create Report tab. If the back button on the web browser is used, PowerAnalyzer might clear the data on the page. When creating a new report, use the Reset button to clear the data from the report. The reset button removes any metrics, attributes, filters, rankings, or formatting that may have been added to the report and takes the report back to Step 1 of the Create Report tab. Once the report is saved, the reset button can be used to clear all settings and create a new report.

10 Selecting Metrics for a Report

This section describes selecting metrics for a report. Metrics are the measures used to evaluate a business process. Metrics are always numeric values. For example, Dollars Obligated, Actions Count, and Base and All Options Value are metrics that are used to report trends in federal government procurement. A report can be created to track specialized construction and where the work was performed for an agency. Metric folders in the Metrics Task Area Directory contain the metrics values. A calculated metric contains a mathematical expression based on metrics from one or more fact tables or other calculated metrics. 

10.1 Reports with Metrics Only

A report can be created using only metrics. Creating a report using metrics only will display how various metrics relate to each other. 

For example: To find out how much money the federal government awarded to companies with revenues higher than 5,000,000.00, create a report with the Base and All Options Value and Annual Revenue. 

10.2 To access the new report screen in Adhoc 

1. Access the Adhoc reporting tool from the main navigation screen.

2. Select the New Button [image: image95.jpg]


 located at the top left side of the reporting screen.  The Create Report Screen will display as shown below.
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The Create Report screen is used to select and enter analytical information for a report.  This screen is divided into four sections designed to create a query for a report. 
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10.3 To Create a New Report in Adhoc

The first step in creating a report is specifying the data for the report.  Section 1 Selecting Metrics adds the measures to evaluate a business process.  Metrics are always numeric values.  For example, Dollars Obligated, Actions Count, and Base and All Options Value are metrics that provide measurable information used to determine trends in federal spending.

Select the add button [image: image98.jpg]


 next to the desired metric(s).  The chosen metric(s) is added to the metric box in section 1.
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Exercise for Adding a Metric to a Report
To add a metric to a report:

Select the Folder where the report is located or select [image: image100.png]



Click the name of the report to highlight the link for the report.

1) Select Metrics. A list of available metric folders displays in the Metric Folders task area and in the Results task area. 
2)  Click the metric that will be added to the report.

Figure 10‑1 Adding a Metric to a Report (1)
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3) Click Add for the metric. Multiple metrics can be added to the report. The selected metrics appear in the box under Select Metrics.

4)  To remove a metric from a report, select the metric that will be deleted from the report, and then click the Remove button.

5)  To change the order of a metric in the report, click the metric, and then click the Move Up or Move Down buttons. The order of metrics in the report determines the order in which the metrics display in the report table on the Analyze tab.

6)  To save the report, click Save.

11  Selecting Attributes for a Report

This section describes selecting attributes for a report. Attributes are the factors that determine the value of a metric.

For example: Date Signed, Product Services Codes, and Contracting Office Names are attributes.  If you want to create a report that tracks Dollars Deobligated and Total Actions for a specific agency, you need to identify attributes that determine the values of these metrics.  In the report, you can specify that you want to see how much money was awarded to contracts with NAICS pertaining to specialized construction contractors and the PSC (Product and Service Codes) that determines exactly what type of construction (i.e. pluming repairs, electrical work, or drywall repairs) your Department/Agency has procured. 

11.1 Reports with Attributes Only

You can create a report with attributes only. You might want to create a report with only attributes to display attribute details. 

 : You might want to create a report that displays the various types of competitive procedures your Department used in the last five years.  You can create a report with the NAICS, PSC, Vendor, Place of Performance and year attributes only. 

For a report with attributes only, if the dimension tables are not linked to any fact table, the attribute values are derived from the primary data source. To create a report with attributes only, do not add metrics on the Create Report screen. The attribute section displays all available attribute folders.  You must select attributes that reside in the same database table. For a report with attributes only, you can set the tabular or sectional report table layout. 

11.2 Adding an Attribute to a Report

You can add attributes to the report from attribute folders on the Select Attributes page. All attributes and attribute folders display for which you have read permission. Depending on the metrics you selected for the report, the related attribute folders will also display. 

11.3 Prompts for Attributes in a Report

You can create a prompt for attributes in a report. You might want to create a prompt to allow the users to select attributes to display in the report. 

You can create a report with prompts that displays Contracting Offices for each Agency in every State for all Non-Competed contracts. When one set of users views this report, they can select the PIID and Place of Performance attributes to display in the report. Another set of users can select the Funding Agency Office attribute to display in the report. 

· After selecting metrics click, Section 2 Selecting Attributes to add an attribute to the report.
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11.4 To Select Attributes for a New Report

Attributes are the factors that determine the value of a metric.  For example, Date Signed, Product Services Codes, and Contracting Office Names are attributes.  If you want to create a report that tracks Dollars Deobligated and Total Actions for a specific agency, you need to identify attributes that determine the values of these metrics. 

· Select the add button [image: image103.jpg]


 next to the desired Attribute(s).  The chosen attributes are added to the attribute box in section 2.
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Exercise for Adding an Attribute to a Report

Select the Attributes window. A list of available attribute folders displays in the Attribute Folders task area. The Attributes display in the Results task area. 
Figure 11‑1 Attribute Folders Task Area
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1) Click the attribute folder from where you want to add attributes. 

2) Click the attribute you want to add to the report.

3) Click Add for the attribute. 

You can add more than one attribute. The selected attributes appear in the box under Select Attributes.

Figure 11‑2 Selected Attributes
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To remove an attribute from a report, select the attribute you want to remove, and then click the Remove button. 

4) To change the order of an attribute in the report, click the attribute, and then click the Move Up or Move Down buttons.

The order of attributes in the report determines the order in which the attributes display in the report table on the Analyze tab. 

5) To create a prompt for attributes, select Prompt Values. 

When you display this report, the reporting tool prompts you to select the attributes you want to display in the report. 

6) To save the report, click Save.

12 Creating Filters

This section describes creating filters. After you select metrics and attributes for a report, you can enhance your report by completing the following tasks: 

· Creating Filters - Filters allow you to set a range for the data you want to display in the report. 

You can use a filter in your report to set a range for the report data. When creating a report, you often need to set a range for the report data. This range depends on the business question that you want answered. You can create the following types of filters: 

· Attribute Filters- An attribute filter sets a range for the report data based on selected attribute values. You select the attribute values by selecting an attribute name, an operator for the filter, and values for the operator.

· Metric filters- A metric filter sets a range for the report data based on selected metric values. You select the metric values by selecting a metric name, an operator for the filter, and values for the operator. 

You can create a report with attribute and metric filters. You can create more than one attribute or metric filter for the report. You can also create filters on attributes or metrics that are not part of the report, but part of the same analytic or organizational schema. 

For example: In the report, you can set a filter to view the data for the last two quarters. In this case, you set a filter on the Quarter attribute, which is not part of the report. When you create a filter, by default, the filter displays in basic mode. In basic mode the filter displays the metric or attribute name, an operator for the filter, and values for the operator. 

Figure 12‑1 Number of Filters in Report
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When you display a report, the filters in the report display in the Filters task area on the Analyze tab. Users can remove the filters from the report. However, you can restrict users from removing filters from reports. If you restrict users from removing a filter from the Number of filters in report the filter does not display in the Filters task area on the Analyze tab. The report always displays filtered data. 

The default filter is the Date Signed filter, the default date range is one year.
· After selecting attributes click, Section 3 Selecting Filters to add a range to the report.
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12.1 To Create Filters on a New Report

You can use a filter in your report to set a range for the report data.  When creating a report, a range is used to limit the search of the query to your specifications.  This range depends on the business question that you want answered.

· The Attribute Filter link will display highlighted in black shown in the following example.  This link is used to access filters for each Attribute.
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· Use the drop down menu to highlight and select the Attribute Filter. 
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· After selecting the Attribute Filter, use the drop down menu to highlight and select the operator that provides the range for the Attribute values.
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· Provide a range for the filter by entering information in the Attribute Value box.
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· Select [image: image113.jpg]


 to save the filter values in the Report Filters section of the screen.
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· The Metric Filter link will display in the Add Filter section.  When the Metric Filter link is selected it displays highlighted in black shown in the following example.  This link is used to access filters for each Metric.
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· Use the drop down menu to highlight and select the Metric Filter.
[image: image116.jpg]Atribute Filler | Metrio Filer

(Create matric filer by selecting  metric, the filler condition and mtiovalue.

For [Seaz e T [orty srom vatves sauet s | =2

r

I Ay tis itr 1o granulrdota, before the dta s sggregated




· After selecting the Metric Filter, use the drop down menu to highlight and select the operator that provides the range for the Metric values.
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· Provide a range for the filter by entering information in the Metric Value box.
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· Select [image: image119.jpg]


 to save the filter values in the Report Filters section of the screen.
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12.2 Updating Filters on a new or existing report

· Filters are stored under the Report Filter Section in section 3 Select Time, Filters, and rankings.  Use the following steps to update Attribute and Metric Filters.

· To make changes to an existing filter Click the blue link of the filter. For example select [image: image121.jpg]Date Signed only show values between "10/01/2003" and '09/30/2004"



. 

· The selected filter link is highlighted in green and displays the information in the Edit Filter section.
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· Make the changes to the filter by selecting information from the drop down menus or entering new information in the Values field(s). 

· When the changes are completed select [image: image123.jpg]


 to store the changes in the Report Filters Section.

Exercise for Creating an Attribute Filter

You can use global variables in attribute filters. A global variable holds any attribute value that you might want to use in a report filter. It allows you to have a different value for an attribute filter each time you run a report without changing the filter.
1. Select Time, Filters, and Rankings 

2. Select Filters. The Filters tab displays.

Figure 12‑2 Attribute Filter Selection Task Area
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3. In the Attribute Filter Selection task area, click Select an Attribute to select an attribute filter.
The attribute list displays the attributes in the current report.

Figure 12‑3 Attributes in the Current Report
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4. From the operator list, select an operator for the filter. If you create a prompt for the attribute filter, you do not need to enter attribute values for the filter. You can skip the following step. If you select attribute values, when you display the report, PowerAnalyzer populates the prompt with those values.

5. Select values for the filter by choosing one of the following options:

· To select values for the filter from the list of available values, click Select Attribute Values.

· The Choose Attribute Values window appears with the first 100 values.

· To search for an attribute value, enter the attribute value in the text box, and then click Search.

 Informatica recommends that you select less than 100 attribute values for each attribute filter.

-Or-

To manually enter an attribute value, click Manually Enter a Value. Enter an attribute value for the filter, and then click OK. Or, enter a value or values in the text box. Depending on the operator you selected the text box might display for the attribute values.

6. To create a prompt for the attribute filter, select Prompt this Filter Before Running

Figure 12‑4 Prompt this Filter Before Running
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When the report displays you are prompted select the attribute values you want to display in the report. The text for the prompt appears in italic to the left of the attribute values.

7. To restrict users from removing a filter from the report, select Restrict Removal of this Filter from Report. The filters do not display in the Filters task area on the Analyze tab.

8. To add another attribute filter to the report, repeat steps 3 to 7. After you add a filter to the report the reporting tool displays another set of filter options in the Attribute Filter Selection task area. The filters are applied to the report in the order in which they appear in the Attribute Filter Selection task area.

9. To remove an attribute filter, click the Remove button for the filter.

10. To save the report, click Save. 

Exercise for Creating a Metric Filter

1) Select Time, Filters, and Rankings

2) Select Filters.  The Filters tab displays
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3) In the Metric Filter Selection task area, click Select a Metric to select a metric for the filter. The metric list displays the metrics in the current report.

4) From the operator list, select an operator for the filter.

5) Enter a value for the filter.

6) To create a prompt for the metric filter, select Prompt this Filter before Running, and then enter the text for the prompt.

When you create a prompt for the metric filter, you do not need to enter metric values for the filter condition. When you display the report, the reporting tool prompts you to select the metric values you want to display in the report. The text for the prompt appears in italic to the left of the attribute values.

7) To restrict users from removing a filter from the report, select Restrict Removal of this Filter from Report. The filter is not displayed in the Filters task area on the Analyze tab.

8) To add another metric filter to the report, repeat steps 3 to 7. After you add a filter to the report, PowerAnalyzer displays another set of filter options in the Metric Filter Selection task area.

9) To change the order in which the filters are applied to the report, click the Move Up or Move Down button to change the order in which the filter appears in the Metric Filter Selection task area.

10) To remove a metric filter, click the Remove button for the filter.

12)  To save the report, click Save.
12.3 Using a Global Variable in an Attribute Filter

You can use a global variable in an attribute filter in a report. You might use a global variable in a filter when the filter condition changes regularly. Using a global variable allows you to update the filter condition without editing the report. You can use any global variable in the repository in a report filter. You can use either prompted or unprompted global variables in report filters. 

Use prompted global variables only in on-demand reports. Global variables can represent different types of values. Before using a global variable in an attribute filter, make sure you know how and when global variable values will be updated. 

When using a global variable in a complex filter expression, make sure the resulting SQL expression is supported by the database for your data warehouse. 

When using a global variable, enclose the name in dollar signs as follows: 

$GlobalVariableName$

If the global variable represents a string or date, you might need to enclose the global variable name in single quotes, depending on how the value is configured in the repository. 

For example: If the Date Signed variable is configured with quotes as “1/1/2003” then you can use the variable without additional quotes. However, if its value is 1/1/2003, you might use the variable in a filter.

12.4 Setting Report Table Layout

The report data displays in a report table on the Analyze tab. There are three types of report tables:

· Tabular

· Cross tabular

· Sectional

12.4.1 Tabular Report Tables

A tabular report table displays attributes as row headers only. By default reports are created with tabular report tables. You can change the table layout to create a report with a cross tabular or sectional report table. A cross tabular report table displays attributes as row and column headers.

12.4.2 Cross Tabular Report Tables

A cross tabular report table displays attributes as row and column headers. By default, reports with time settings are cross tabular. The time settings display as column headers in the report table. If the report contains other attributes, you can place them as column headers or row headers.

12.4.3 Sectional Report Tables

A sectional report table displays the report data in sections. The sections are based on an attribute and each section in the report table represents a unique attribute value. Within each section, attributes can display as row and column headers. If you have a report with a large number of rows, you can divide the report table into sections based on an attribute in the report. Each section represents a unique attribute value. 

When a sectional report table displays on the Analyze tab, by default, PowerAnalyzer displays all sections. From the attribute value list, you can clear attribute values for the sections you do not want to show in the report table. To clear all attribute values, click Clear. 

You can also select to display a summary of the report. When you display the summary report all attribute values are displayed for the attribute in the sections and the subtotals for each. Any other attributes are hidden. The reporting tool also displays a grand total for the metric values in the report. 

For example: If you display the summary in the table, the reporting tool hides the Subcategory attribute. The report table displays dollars obligated and actions subtotals for each category, and the total amount obligated and actions performed.

You can create sectional report tables based on more than one attribute. 

When you add a chart to a report with a sectional report table, by default, the chart is created for the first section in the report. On the Analyze tab, you can add charts for the other sections. After you add charts for the other sections, the report displays separate charts for all the sections that appear on the Analyze tab.

12.5 Displaying Metrics as Rows

By default, all metrics in a report display as columns. If you want to create a report that displays metrics as rows, you can change the table layout. You cannot create a report with metrics as rows and columns. You can display metrics as rows in tabular, cross tabular, and sectional report tables. The following figure shows a tabular report table with metrics as rows:

12.6 To Format the Report

The final step in creating reports is selecting the formatting for the report.  Section 4 Layout and Setup is used to customize the visual display of your report.  Calculations can be added for metric filters in the report.  You can also modify the date formats, display, and fonts in the report.  Use the following steps to format a report.

To add a sections to a report select the Table Layout Tab.

To create the report with sections, drag an attribute to the Section Attribute area.  The selected attribute displays in the Section Attribute area.  You can also drag attributes from the Section Attribute area to the Row Attribute or Column Attribute areas.
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Creating sections in a report will display the report divided by the attribute you have chosen. For example, choosing the funding agency ID will display the report information in sections for each ID.

To add a calculation to the report, select the Calculating Tab. The following screen will display.
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Select the drop down menus next to Show seen in the following example.
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Select the type of calculation desired for a metric filter.

Select the drop down menu to select the metric for the previously chosen calculation.
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To display the subtotals for a specific column click the check box and select the drop down menu for Show Subtotals.  Click the attribute that will display the subtotals. 
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Select [image: image133.jpg]


 to place the calculations in the Summary section.
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To change the formatting for the report, select the Formatting Tab.  The following screen will display.
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You select formats for metrics and attributes on the Formatting tab.  These formats determine how the metrics and attributes display in the report table.

To keep the changes made to the report formatting select [image: image136.jpg]


 or [image: image137.jpg]


.

The save as function will allow you to make changes to the query and save the changes without overwriting the original query.

Exercise for Setting Report Table Layout

1) Select Table Layout.
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2) To create a Sectional report, from the Row Attribute area, drag an attribute to the Column Attribute area. The selected attribute displays in the Column Attribute area. 

3) The report will display in sections as defined by the attribute you selected.

4) To save the report, click Save.
Exercise for Creating a Calculation in a Report

1) Select the Calculations Tab. 
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2) Select the type of Calculation.
3) Select the drop down menu next to Show and choose an operation.
4) Select the drop down menu next to for and choose the metric for the calculation.

5) Select Add to place the calculation in the Report.
12.7 Creating a Report Table Sort Order from Layout

You can create a sort order to sort the rows in a tabular report table based on attribute or metric values. You can also create a sort order to sort the columns in a cross tabular report table or the sections in a sectional report table. You can sort the report rows, columns, and sections in ascending or descending order. You can also create a nested sort order.  If you sort report data based on an attribute and if the report contains many rows with the same attribute values, you can sort these rows based on another attribute or metric. 

The following figure shows a report table sorted on the category attribute and then the actions count attribute.

Figure 12‑5 Nested Sort Order 
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When creating a nested sort order, you can sort on attributes and metrics in ascending or descending order.  If you sort the report data by the day of week attribute in descending order, the reporting tool displays the rows in the reverse order of the sort sequence.
If your system administrator does not create a sort sequence and if you sort the report data by the day of week attribute in ascending order, the reporting tool displays the rows in alphabetical order. Similarly, in descending order, the rows are displayed from Z to A. 

In a report with multiple attributes, if one or more attribute has a sort sequence, the reporting tool sorts all the attributes in the report table by default. When you sort report data, the reporting tool treats any null metric value as the smallest value. In a report with time settings, the reporting tool uses row totals to sort the rows in the report table. If the report has multiple time settings, the reporting tool sorts the columns in the first time setting only. 

Exercise to Create a Report Table Sort Order

1) Select Layout and Setup 
2) Select Sorting.
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3) The Sorting tab displays. If the report has a tabular report table, the Sorting page displays the sort options for the rows in the report.

4) To sort the rows, select an attribute or metric in the first Sort By list. 

5) Select Ascending or Descending as the sort order. 

6) To create a nested sort order you can create three levels of nested sorting.
7) To save the report, click Save.

8) Execute the report.

9) Enter a Date Range (for example 01/01/2005 to 01/10/2005).

10) Display the report.

Adding a Chart to a Report

You can create charts for a report when you create the report or when you edit a saved report. You can display multiple charts for a report. The reporting tool displays the report chart along with the report table when you open the report on the Analyze tab. A report chart displays the report data as a chart on the Analyze tab. 
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12.8 Displaying Data in a Chart

When you display data in a bar, line, or combo chart, the chart contains the following components:

· Groups - Categories that the reporting tool uses to organize data in a chart. For example, on a standard bar chart, groups display on the x-axis.

· Series - Data items for each group. The reporting tool displays each data series in a unique color. 

For example: On a standard bar chart, series display on the y-axis.  Each group contains a series of data. Except for pie and multi-pie charts, the reporting tool displays labels for series on the chart legend. You need at least one group and one series to plot a pareto chart. 

Depending on the chart type, you may need more groups or series of data. 

For example: You need at least three groups of data to display bubble and waterfall charts.  When you display a chart, the reporting tool displays an error message if you do not have enough groups or series of data in your table.  Report charts display up to 500 data points.  You can calculate the number of data points in a report by multiplying the number of rows by the number of columns.  You can also set the size of the report chart.  If the report chart size is too small for the report labels, the report chart displays cropped labels. 

You can plot the chart in the following ways:

· Draw series along table rows - The reporting tool plots each row in the table as a series on the chart.

· Draw series along table columns - The reporting tool plots each column in the table as a series on the chart.
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12.9 Report Chart Types

You can create the following types of charts for reports:

· Standard bar - Displays data as vertical rectangular bars.

· Stacked bar - Displays data as vertical rectangular bars stacked on each other, where each stack represents a series of values. 

· Horizontal bar - Displays data as horizontal rectangular bars. 

· Horizontal stacked bar - Displays data as horizontal rectangular bars stacked on each other, where each stack represents a series of values. 

· Pie - Displays percentage data values as proportionally-sized slices of a pie.

· Multi-pie - Displays data as pies, where each pie represents the metric values for each of the report metrics.

· Standard line - Displays data as lines. 

· 2Y line - Displays data as two lines, each with its own Y axis. Both lines share the same X axis.  The two Y axes may have different scales.  You can use a 2Y line chart to compare values of two series of data. 

· Stacked line - Displays data as lines stacked on each other, where each line represents the metric values for each of the report metrics.

· Area - Displays data as lines with the area beneath the lines filled in.  An area chart can plot two or more data points.

· Stacked area - Displays data as filled-in lines stacked on each other, where each area represents a series of values.  A stacked area chart can plot two or more data points.

· Combo - Displays data as a combination of bar and line charts.  The reporting tool displays the first series in the report as a bar chart and the second series as a line chart, each with its own Y axis. Both series share the same X axis. The two Y axes may have different scales. If the report consists of a single metric, the combination chart is equivalent to a bar chart. 

· Stacked bar combo - Displays data as a combination of stacked bar and line charts.  The reporting tool displays the first three series of data in the report.  The first two series of data in the report display as a stacked bar chart and the third series display as a line chart.  The first two series display with their own Y axis.  Both series share the same X axis.  The two Y axes may have different scales.  If the report consists of a single series of data, the combination chart is equivalent to a stacked bar chart. 

· Scatter - Displays data as points, where each point represents two metric values.  In a scatter chart, both X and Y axes represent metric values.  A scatter chart can plot two or more data points. 

· Standard waterfall - Displays data as cumulative metric values, where each value is the sum of the previous value and the current value.  The reporting tool displays the next incremental values as bars.  The standard waterfall chart resembles a staircase.  When you update the report, the reporting tool automatically updates the chart with the new values.  You can use a standard waterfall chart to show a trend in metric values along an attribute.  

· Horizontal waterfall - Similar to the standard waterfall chart displays cumulative values as horizontal bars, where the positions of the X and Y axes are reversed. 

· 2Y bar - Displays two bar charts, each with its own Y axis.  Both bar charts share the same X axis.  A horizontal line separates the two bar charts.  For better readability, the reporting tool displays the Y axis labels on the alternate sides of the chart.  You can use a 2Y bar to compare values of two metrics or attributes. 

· 3Y bar - Similar to the 2Y bar chart displays three bar charts. 

· 4Y bar - Similar to the 2Y bar chart displays four bar charts. 

· 5Y bar - Similar to the 2Y bar chart displays five bar charts.

· Bubble - Plots metrics as bubbles on the chart, where each bubble represents three metric values in the first series of the first three groups. The first metric value determines the x-axis position of the bubble, the second metric value determines the y-axis position of the bubble, and the third metric value determines the size of the bubble. Each bubble displays in a different color or pattern.  You can create bubble charts for reports with tabular and sectional report tables. If the report contains more than three metrics, you can select any three metrics to plot the bubble chart. If you do not select any metrics, the reporting tool uses the first series of the first three groups in the report to plot the bubble chart. You can use the bubble chart in a report when you want to compare the metric values against each other. 

· Pareto - Plots data as cumulative percentage to display the importance of differences between groups. A Pareto chart displays each group along the x-axis and the first series along the y-axis up to the percentage threshold you specify.  Data groups that are greater than the percent threshold display in a 

· Geographic - Provides a map representation for attributes that represent geographical regions.  You can display a geographic chart for a report with one attribute and a tabular report table.  
12.10 Displaying Metric Formats in a Chart

When you select a metric for a chart, you can also select an axis that you want to display according to the format for the metric.  You select formats for metrics on the Formatting tab.  These formats determine how the metric displays in the report table. 

For example: You can display a metric in the currency format, or you can display a metric with the thousand scales. 

In the report chart, you can format the different axes according to different metric formats.

To display different axes formats in the chart, make sure you select a chart type that displays multiple axes. 
To select a metric for a chart 

1) Select Show More Chart Options [image: image144.bmp]
2) Select Show Values for

3) Select a metric
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Exercise to Add a Report Chart

When you add a report chart, you can specify the type and size of a chart.  The reporting tool auto sizes any text in the chart and uses a default font for the text.  When you add a chart to a report with a sectional report table, by default, the reporting tool creates the chart for the first section in the report. 

On the Analyze tab, you can add charts for the other sections in the report.  To add a report chart: 

1) From the Layout and Setup page, click Charting.

2) Click  Add New
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The chart toolbar displays.

3) To display the chart based on row or column data, click Draw Series along Table Rows or Draw Series along Table Columns. 

4) To hide the report chart in the Analyze tab, click Hide Chart.  By default, the reporting tool displays the report chart in the Analyze tab when you add a chart to the report.
5) Select chart type

6) Click on Show More Options

7) Click on Show Values for

8) Select a metric

9) Click OK.

10) To add another chart to the report, click Add New Chart.

11) To view the chart, click Save.  You will see the chart in the Layout box.  Click Execute.

12) To save the report, click Save.  After you add charts to a report, the reporting tool displays the number of charts in the Layout tab.

13 Running a Report
After you create a report, you can display it on the Analyze tab and check the report to ensure that it displays the information you want. If the report does not display the data you want, you can edit the report. You can also view the SQL query for a report. If you are proficient in SQL, you can edit the SQL query for the report to quickly modify the report. When you edit the SQL query, you can include stored procedures in the SQL statement. Once you are satisfied with the data and format of the report, you can save it. The reporting tool saves the report in the repository. The reporting tool users can now access this report from the content folders. You can perform the following tasks after you create a report:

· Display report results

· Save the report

13.1 Displaying Report Results

You can run a report to display the results on the Analyze tab.  When you run an on-demand report, the reporting tool displays updated data from the data warehouse.  It displays metrics and attributes for which you have read permission.  If the report contains metrics or attributes for which you do not have read permission, the reporting tool does not display filters on these metrics or attributes.  When you run a cached report, it displays cached data that was refreshed on a predefined schedule.  If you edit a cached report, the reporting tool accesses the data warehouse to retrieve current data.  When you save the edited report, the reporting tool prepares a new cache for the report.

13.2 Displaying Reports with Prompts

You can save reports with prompts as on-demand reports only.  You might want to use prompts to modify the data you want to display in the report.  When you view a report with prompts, the reporting tool displays a summary of the components of the report for which you can create prompts.  The summary includes the current values for metrics, attributes, attribute filters, and metric filters.  The reporting tool prompts you to select the values for the components for which the report owner had created prompts.  The following figure shows how the reporting tool prompts you to select attributes and metrics:
Note: For reports with tabular report tables, all attributes display in the By Row task area. For reports with cross tabular report tables, attributes display in the By Column or By Row task area. For reports with sectional report tables, attributes display in the By Section, By Column, or By Row task area. 

When you view a report with a prompt based on an attribute or metric filter, the reporting tool prompts you to select the values you want to display in the report.  When you created the filter, you entered values for the filter condition.  The reporting tool displays these existing values in the prompt. 

You can add or delete values.  If you did not enter values for the filter condition when you created the filter, the reporting tool does not display any values in the prompt.  You can select values for the filter.  If the prompts are based on more than one attribute filter, you can use progressive filtering in the prompts.  Progressive filtering allows you to select attribute values for a second filter based on the attribute values you select for the first filter. 

By default, the reporting tool displays the prompts every time you run the report.  If you select certain prompt settings, you can choose to display those settings the next time you run the report.  When the reporting tool prompts you the next time you run the report, the reporting tool displays the settings you selected the last time you ran the report.  After the report displays on the Analyze tab, you can display the prompt again to select different values for the prompt.

Exercise to Display Report

1) From the Create Report tab, click the Display Report button.

-Or-

Open a report from the Find tab. 

For an on-demand report with prompts, the reporting tool prompts you to select the settings to display in the report.

2) To display the selected prompt settings the next time you view the report, click Prompt me with These Settings the Next Time I Run the Report. 

3) Select values you want to display in the report:

If the prompts are based on attributes or metrics, clear the check boxes for any attribute or metric you do not want to display in the report. 

If the report prompts are based on a filter, select attribute values you want to display in the report. To add additional attributes values to an attribute filter, click the Select Attribute Values link. Click the attribute values, and then click OK. 

If the prompts are based on a metric filter, enter a value for the filter condition. 

4) If the prompts are based on attribute filters, to display attributes values in a progressive manner, click Enable Progressive Filtering. 

5) Click Display Report. 

6) To edit the report, on the Analyze tab, click Edit Report.  The report appears in the Create Report tab. Make the necessary changes and save the report. 

7) To display the prompt again, on the Analyze tab, click Re-run Prompt.

13.3 Saving a Report
 You can save reports with prompts as on-demand reports.  You can save a new report from the Create Report tab or from the Analyze tab.  You can also save an existing report as a new report.  When you save a report, the reporting tool prompts you to enter values for the following report properties:

· Comments

· Description

· Keywords

If you entered values for these properties in section 5 on the Create Report tab, the reporting tool populates the fields with those values. To save a report as a cached report, you must have write permission on the report.

Exercise to Save a Report

1) On the Create Report tab, click Save.

-Or-

On the Analyze tab, click Save.

Note: The Save Report window displays options to configure report settings and properties the first time you save a report. All subsequent saves do not display these settings and properties.

2) Enter a name for the report in the Report Name field.  Maximum length for the report name is 255 characters. The report name can include any character except a space, tab, new line character, and the following special characters: / \ : * ? “ < > |

3) Click Select Folder to select a location to save the report. The Select Folder window appears. In the Select Folder window, navigate to the location you want to save the report, and then click OK.

4) Enter the following report properties
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5) Click OK.

14 Working with Reports

On the Analyze tab, you can perform the following tasks when working with a report: 

· Save an existing report as a new report
· Print a report
· Export a report 
· Email a report 

· Display a report as a PivotTable
· Edit a report
14.1 Saving an Existing Report as a New Report

From the Analyze tab, you can save an existing report as a new report.  You might want to save an existing report as a new report when you want to edit a report but do not have write permission on the report. When you save the report, you specify the report type as on-demand or cached.  When you save an existing report as a new report, you become the owner of this new report with write permission on the report. You can save a report with a new name in a different location.  You can also save an on-demand report as cached report, or a cached report as an on demand report.  You cannot save an on-demand report with prompts as a cached report.  Once you save an existing report as a new report, you can change the comments, descriptions, and keywords associated with the report.  You can also select the category, department, and query governing settings for the report.  When you save an existing report as a new report, the reporting tool does not save the highlighting rules associated with the report. You must create these rules again in the new report. 

Exercise to Save an Existing Report as a New Report

1) Open the report that you want to save as another report.  The report displays on the Analyze tab.
2) Click Edit.

3) Click Save As.

The Save As Window appears.

4) Enter a name for the report in the Report Name field. Maximum length for the report name is 255 characters.  The report name can include any character except a space, tab, new line character, and the following special characters: / \ : * ? “ < > |

5) Click Select Folder to select a location to save the report. The Select Folder window appears. 

6) In the Select Folder dialog box, navigate to the location you want to save the report. 

7) Click OK to close the Select Folder window.

8) Enter the following information for the report.
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9) Click OK.  The reporting tool saves the report to the repository.

10) Click Close.
14.2 Printing a Report
You can print a report from the Analyze tab.  You can print the report with a portrait or landscape orientation.  If the report contains filters, you can hide the filters in the printed copy.  For a report with sectional report tables, you can display each section on a separate page.  Before you print a report, the reporting tool displays the report as a PDF document in a new browser.  You need Adobe Acrobat Reader version 4.0 or later to display the report.  If you do not have Adobe Acrobat Reader installed on your machine, the reporting tool prompts you to save the report as a PDF document to your computer. After you install Adobe Acrobat Reader, you can view and print the PDF document.
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Exercise to Print a Report

1) Open the report you want to print.  The report displays on the Analyze tab. 
2) Display the report.

3) Click [image: image150.png]Export



. The Export window appears.
4) Select the format and Display options in the Export window.
5) Click Excel or PDF. 

6) Click [image: image151.png]Boot



, Click Open.
7) Excel or Adobe Acrobat launches in a new browser window to display the report.
8) From the File menu in the new browser window, choose Print to print the report to your printer.

14.3 Exporting Report Data

You can export report data to a file in any of the following formats:

· Microsoft Excel – Retains the report formatting when exported to an Excel spreadsheet.
· Comma Separated Value (CSV) Document 
· HTML Document - If the report contains any filters, you can hide the filters in the HTML document. 

· PDF Document - You can export the file in the portrait or landscape orientation.  For a report with sectional report tables, you can display each section on a separate page.  If the report contains any filters, you can hide the filters in the PDF document.  When you export the report to PDF format, the reporting tool displays the report as a PDF document in a new browser window.  You need Adobe Acrobat Reader version 4.0 or later to display the report as a PDF document in a new window. If you do not have Adobe Acrobat Reader installed on your machine, the reporting tool prompts you to save the report as a PDF document to your computer.  After you install Adobe Acrobat Reader, you can view the PDF document.

When you export report data, the reporting tool creates a file in the specified format.  You can save this file to your local drive.  Exporting a report to another format allows you to send the report to someone outside your organization.  You can also use the exported report in another program, such as Excel, Acrobat, or DreamWeaver.  System administrators can also export report definitions to an XML file.  You need the Export Report privilege to export report data. 
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Exercise to Export Report Data

1) Open the report you want to export. 

2) Click Execute to run the report.

3) Click  [image: image153.png]Export



.

The Export window appears.

4) Select the format for export.  If you select HTML format, to hide filters in the exported report, select the Hide Filters in Exported Report check box.  If you select PDF format, select the orientation and display options.

5) Click  [image: image154.png]Export



. 

6) Save the file to your local drive.

Note: If the report name contains a period (.), the reporting tool replaces the period with an underscore (_) in the exported file name.

14.4 Exporting Report Data to Excel

You can choose several ways to export report data to an Excel file.  You can choose to retain the reporting tool formatting in the Excel file or use the formatting and functions in an Excel template.  You can also export the report data to an Excel PivotTable to use advanced Excel functions.  The Excel file retains custom metric and formatting.  When you choose the Excel PivotTable or Template options, you can refresh data in Excel.  You cannot refresh data when you choose the Retain the reporting tool Formatting option.  To refresh data, you must first install the Microsoft SOAP toolkit on the machine where you save the Excel file.  When you export report data to an Excel file, choose from the following options:

· Retain report formatting - The reporting tool creates a new Excel file and writes the report data to the file.  The file retains the formatting you see in the Analyze tab in the reporting tool. You can then view and save the file.

· Export to Excel PivotTable - The reporting tool creates a new Excel PivotTable that uses a macro to refresh data.  An Excel PivotTable is an interactive report that summarizes data and allows you to rotate columns and rows.  The Excel PivotTable does not contain any formatting you set in the reporting tool.  Choose Export to Excel PivotTable if you want to use Excel to perform further analysis on the report data using advanced Excel functions.  For details on using Excel PivotTable reports, see your Microsoft Excel documentation.

· Export using a template - The reporting tool creates a new Excel file based on an existing Excel template that you have uploaded in the reporting tool repository.  The new Excel file contains formatting specified in the template.  Choose Export Using Template if you want to standardize the format of a report table.

Note: Before you can export to an Excel PivotTable or use a template, you must set Excel to Medium Security level permission to enable macros.  You can set security level in Excel by choosing Tools > Macros > On Security level.

14.5 Retaining Report Formatting

When you choose the Retain the reporting tool Formatting option, the reporting tool creates an Excel file that contains the data in the format you see on the Analyze tab.  You can edit and format the Excel file after you export the report 
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When you choose the Retain the reporting tool Formatting option, the reporting tool retains the formatting you see on the Analyze tab.  The following figure shows the Excel file created by exporting the report, using the Retain The reporting tool Formatting option.
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Exercise to Retain report Formatting when Exporting Report Data to Excel

To retain the reporting tool formatting when exporting report data to Excel:

1) Open the report you want to export.  The report displays on the Analyze tab. 

2) Execute to run the report.

3) Click  [image: image157.png]Export



. The Export Report window appears.

4) Click Microsoft Excel. 

5) Choose Retain the reporting tool formatting. 

6) Click  [image: image158.png]Export



. Click Open, the Excel file displays in a new browser window. 

7) Save the Excel file to your local drive.  You can now edit and format the Excel file.

14.6 Emailing a Report
You can email a report from the Analyze tab or the Find tab.  The reporting tool attaches the report to your email in the format you select. You can attach the report in the following formats:

· Link Only 

· PDF Document 

· Embedded HTML

· Microsoft Excel

· Comma Separated Value (CSV) Document

You can also choose to include a hyperlink to the report in the body of the email. The reporting tool uses your reply-to email address as the From address for the outgoing email.  You can add a reply-to email address on the Web Settings page of the Manage Account tab.  If you do not have a reply-to email address, the reporting tool prompts you to enter a From email address.

Exercise to Email a Report

1) Execute the report you want to email.

The report displays on the Analyze tab.

-Or-

On the Find tab, click the report you want to email.

2) Click  [image: image159.png]


 Report from the Ad Hoc reports  -OR- Click [image: image160.png]


 from My Reports.

3) Choose the format to send the report.

4) Click  [image: image161.png]


.

Note: On the Find tab, the Details task area displays the Email Report button. The Email Report window appears.

Figure 14‑1 Email Report Window
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5) Or you will see this email screen if you are emailing an Ad Hoc report
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6) If you do not have a reply-to email address, enter your email address in the From field.

7) Click [image: image164.png]


. The reporting tool sends the email to the specified recipients.

15 Working with Report Data

When you open a report, the reporting tool displays it on the Analyze tab. From the Analyze tab, you can view report data. You can also modify the report data.  The report data displays as a table on the Analyze tab. The report table consists of attributes and metrics.  These attributes and metrics display as row or column headers in the report table.  You can also choose to display report data as charts on the Analyze tab. You can perform the following tasks on the Analyze tab to customize report data:

· Highlight metric values.  You can highlight metric values to identify important data, trends, and patterns at a glance. 

· Add or remove a filter - You can set attribute or metric filters on the data. 

· Drill into a report - You can drill into a report to display other attributes or metrics related to the current report. You can also shift from a general view of the report data to a more detailed view.  

· Display report charts - You can display the report chart on the Analyze tab. You can change the type of chart you want to display on the Analyze tab. 

· Add a related report or document - You can create links to similar reports and related shared documents. These links can provide the users quick access to important, related information.  

· View help glossary definitions - You can view descriptions of the attributes and metrics of the report.

· Change the data display - You can change the way the reporting tool displays the data in the report table.

15.1 Highlighting Metric Values
Highlighting metric values in a report table is accomplish by using colors, patterns, or symbols.  You can highlight metric values in a report that are above, below, or within a range.  Highlighting draws attention to critical data in a report or pinpoints problem areas.  This is useful in reports with multiple metrics or many rows of data. 

The first step to highlighting values in an on-demand, cached, or real-time report is to create a highlighting rule.  A highlighting rule can be created for any metric or calculation in the report. 

After a highlighting rule is created the reporting tool highlights the values in the report table.  The highlighting rule name is displayed in the active filters task area on the Analyze tab.

If metric values are highlighted in a report, the highlighting also appears in all bar charts, bar chart indicators, or table indicators created for that report.  In the charts and chart indicators, the reporting tool displays highlighting as colored dots.  Colored dots are a type of highlighting format. 

Note: The reporting tool does not highlight null values.  You cannot modify the highlighting directly in the charts or indicators.  To modify highlighting in the charts or indicators, you must modify the highlighting rule.

15.2 Creating a Highlighting Rule

To create a highlighting rule, you can specify the following properties for the highlighting rule:

· Ranges

· Color codes

· Formats

· State of Rule

· User access

· Additional display options 

15.3 Specifying Ranges

When creating a highlighting rule three ranges are used to specify (low, medium, and high) for the values the reporting tool will highlight.  Numeric values that correspond to the values in the report table must be entered.  These ranges must be in ascending order.  For example, to create a highlighting rule for the Total Dollars Obligated metric decide the low, medium, and high ranges for this metric. 

After specifying ranges, set a color code for highlighting each range or use the system default color.  The color code provides a visual cue about the highlighted values.  For example, if the highlighting rule is for the dollars obligated metric, you can specify the high values as green.  If the highlighting rule is for the Total Actions metric, you can specify the high values as red.  If you do not select any color for a range, the reporting tool does not highlight the values within this range.

15.4 Choosing Formats
You can choose a format for the highlighting rule.  The format determines how the reporting tool highlights the values in the report table.  Choose from one of the following formats:

· Colored dots - The reporting tool displays colored dots next to each highlighted value.  The color of the dot depends on the color code you select in the highlighting rule.

· Background color - The reporting tool displays a background color for each highlighted value. The background color depends on the color code you select in the highlighting rule.

· Harvey images - The reporting tool displays black-and-white dots next to each highlighted value.  The type of dot depends on the color code you select in the highlighting rule.  A full dot represents high values, a half full dot represents medium values, and an empty dot represents low values.

· Arrow indicators - PowerAnalyzer displays black-and-white arrows next to each highlighted value.  The type of arrow depends on the color code you select in the highlighting rule.  An up arrow represents high values, a dash represents medium values, and a down arrow represents low values.

· Symbols - The reporting tool displays colored symbols next to each highlighted value.  The type of symbol depends on the color code you select in the highlighting rule. A green dot represents high values, a yellow triangle represents medium values, and a red square represents low values.

15.5 State of Rule

You can set the state of a highlighting rule as active or inactive.  An active highlighting rule highlights values in the report table.  An inactive highlighting rule is stored in the repository, but does not highlight values in the report table.  Multiple highlighting rules can be created for any metric or calculation in the report.  However, the reporting tool only allows one active highlighting rule for each metric or calculation. 

In the Highlighting task area on the Analyze tab, a green dot marks an active highlighting rule and a red dot marks an inactive highlighting rule.  For public highlighting rules, you can also set the default state for the highlight rule.  The default state for the rule, which can be active or inactive, applies to all the reporting tool users.  This allows you to set a different state for yourself than all the other users of a report.

15.6 Display Options
You can choose to display highlighting only in the report table and hide the metric values.  You can use this option if the metric value is incidental in the report and you want to focus on a visual representation only. 

You want to highlight the suppliers according to their ratings so that you can identify your best and worst suppliers at a glance.  The actual rating numbers are not important.  You can create a highlighting rule where the reporting tool displays highlighting only in the report table and hides the rating values.  In a cross tabular report table or in a report with time settings, by default, the reporting tool highlights all occurrences of the selected metric.

15.7 Steps for Creating a Highlighting Rule

To create a public highlighting rule, you must have write permission on the report.  To create a personal highlighting rule, you must have read permission on the report. 
1) Execute the report where you want to create a highlighting rule

2) Click on the metric name to create the highlighting rule

3) Click highlighting
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4) Enter numeric values for each of the four value boxes

5) Select how the highlighting will be displayed (Optional)

6) Enter a name in the Name highlighting rule field
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7) Click OK.  You will see the highlighting displayed in the report table.
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8) Exercise to Create a Highlighting Rule

1) Open the report where you want to create a highlighting rule.  The report displays on the Analyze tab.

2) Click the metric name for which you want to create the highlighting rule.  The reporting tool selects the column for the metric. 

3) Click Highlighting.
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4) Enter the following information:

	Property
	Required/optional
	Description

	Name the highlighting rule field
	This field is required
	This field is used to name the highlighting rule. After the highlighting rule is named, and then saved, it is stored on the Analyze section where it can be edited or deleted.  

	Specify numeric values for each field
	These fields are required 
	The fields available specify numeric values for ranges for the metric or calculation. 

The ranges must be in ascending order.

	Then highlight
	This function is optional
	Select colors for each range of values.  The system defaults with red for low numeric values, yellow for medium numeric values, and green for high numeric values. 

	Specify formatting for highlighting
	This function is optional
	Select the type of formatting you want to use for highlighting the range of numeric values. The system defaults with a background color for each numeric value.

	Set Highlighting Rule As
	Optional
	Select one of the following options to set the state of the highlighting rule: 

· Active

· Inactive

The system default is active.

	More Options
	Optional
	Select to display additional fields for the highlighting rule.

	Show Only Highlighting in the Table and Hide Numeric Data
	Optional
	Select this function to show highlighting only in the table.  By default the system highlighting and numeric data appear in the report table. 

	Control user access of a highlighting rule. 
	Optional
	Select one of the following options to set user access for highlighting.

· Public

· Personal

The system defaults to public.

	Apply Highlighting Rule on All Occurrences of Selected Metric in the Report
	Optional
	This option displays for cross tabular report tables and reports with time settings.  By default the system highlights all occurrences of the selected metric in the report table.  Clear the check box to highlight one occurrence of the selected metric.


5. Click OK. The highlighting rule appears in the Highlighting task area on the Analyze tab.  The highlighting is displayed in the report table.

15.8 Modifying a Highlighting Rule

You can modify the name, value ranges, colors, format, state, and user access of a highlighting rule.  To modify a public highlighting rule, you must have write permission on the report.  To modify a personal highlighting rule, you must have read permission on the report.  If you only have read permission on a report, you can view any public highlighting rules in the report.  You can activate or deactivate a public highlighting rule in the report.  You cannot modify the rule in any other way.

Exercise to Modify a Highlighting Rule

1) Open the report where you want to modify a highlighting rule.  The report displays on the Analyze tab.

2) Click Activate to activate an inactive highlighting rule.

3) To modify any aspect of the highlighting rule, in the Highlighting task area, click the highlighting rule name.  The reporting tool displays the Highlighting tab.
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5) On the Highlighting tab, make the necessary changes.  Click OK.
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15.9  Deleting a Highlighting Rule

When you delete a highlighting rule, the reporting tool deletes the highlighting from the report table and the highlighting rule name from the Highlighting task area.  To delete a public highlighting rule, you must have write permission on the report.  To delete a personal highlighting rule, you must have read permission on the report.

 Exercise to Delete Highlighting

1) Open the report where you want to delete a highlighting rule.  The report displays on the Analyze tab.

In the Highlighting task area, click the highlighting rule name.  The reporting tool displays the Highlighting tab.

[image: image171.png]2 ] oo | o | e e

EditHighlighting Rule:
Use the tools belom to sditthis highiighting rule.

Name highighting rle:  [Actin Obiigaion e ]

Specity highlighting rule: Aofion Obligation

Erter valuss: [sa00 ][00 ] oo ][00

show: [ banes 2] — | Vet <] | erm—

Selsctformst: TS specifes Fow hghlghtieg wil appear i tabe el

@ [A 00| [0 100 [0 ow| [E 0w @ om0
‘A 5000 © s000 © som ~ s o som
2,000 A 2000 ® 2000 o zom B zom 2 200

Set highiighting state: (5 Active (* Inactive

B More options.





2) Click [image: image172.png]


.  The reporting tool deletes the highlighting from the report table and the highlighting rule name from the Highlighting task area.

15.10 Drilling into a Report

You can drill into a report to see more details about the report data for a more detailed view.  When you drill into a report, you select attribute values for the drill.  The reporting tool uses these attribute values as a drill filter.  The drill filter determines the data you see in the drill results.  You can select more than one attribute value for the drill. You can select multiple attribute values in one of the following ways:

· Select multiple attribute values in the report table.

· Click an attribute name to select all attribute values.

When you drill into a report, you select an additional attribute from a predefined drill path.  You can select an attribute higher or lower in the drill path hierarchy than the current attribute in the report.

1) Execute the report where you want to conduct a drill

2) Click on the attribute name or attribute values to create the drill filter 
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3) Select the attribute to drill down to and to be displayed in the report.
4) Click on [image: image174.png]rill



. You will see the additional attribute in the report. The drill results display only the attribute values you selected for the drill path.
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Or-

In the report table, right-click the selected attribute, and then click on the attribute for the drill to view available drill paths.

You can select those attributes from the available drill paths that are not already part of the report. 
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To go back to a previous drill result, click on the drill result link in your current drill path.  To go back to the original report, click on the Original Table link in your current drill path.

Exercise to Drill into a Report

1) Open the report you want to drill into.  The report displays on the Analyze tab.
2) Select the attribute value for the drill.  You can select more than one attribute value for the drill filter.

3) Shift-click to select a contiguous range of values.

4) Ctrl-click to select a non-contiguous range of values.  You can also click a metric value to select all associated attribute values.

5) To select all attribute values for an attribute, click the attribute name. 

6) Click Drill. The reporting tool displays the available drill paths on the Drill tab.

-Or-

In the report table, right-click the selected values, and then click Drill to view available drill paths.

You can select those attributes from the available drill paths that are not already part of the report. 

7) From the available drill paths, select the attribute you want to display in the report. 

8) Click Drill. The report displays with the selected attribute. The data in the report depends on the attribute values you selected for the drill filter. To drill further into the report, repeat steps 2 to 5. 
9) To go back to a previous drill result, click the drill result link in your current drill path. To go back to the original report, click the Original Table link in your current drill path.
16 ezSearch
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  Easy search provides the ability to search for contracts based on free text.  All contracts searched are in Final status.  Any DoD contract that is less than 90 days old will not be included in the search.

1.  To begin your Easy Search type in one or more keywords that will be searched for in the contracts that you would like to find.  
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2.  Click on the [image: image179.png]


 button.  A list of contracts will be displayed that matches your search criteria in the Results page section.  To remove your search criteria text, click the [image: image180.png]Clear

y



 button.

3.  You can refine your search by using the four filter boxes on the left side of the screen.  You can drill down by Department, Agency, Vendor and Vendor State.  The information in each filter box is displayed in descending order. Only the top 10 results will be displayed. The user can further drill down on a Department or Vendor State.
Click on the appropriate link in each filter box.  Your results will be displayed in the Results Page section.
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Search Criteria 
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The Search Criteria box located in the top right corner of the screen displays your current search criteria.. To remove the criteria or a portion of the search criteria click the [image: image183.bmp] button next to each search level.

Sort By 
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The Sort By box allows the user to sort the existing list of contracts by various fields within the contract.  For example you can sort the existing list of contracts by Date Signed or Contract Type.  Click on the appropriate field to Sort By.  Only one Sort can be conducted at a time.

Recent Searches 
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The Recent Searches box maintains a list of recent searches that were performed.  Click on the desired search criteria link to conduct the search.   FPDS-NG maintains the list of searches until the clear link is selected.  When you click on ‘Clear’ all searches are removed.

Clicking on the links inside the documents allows you to further refine your search and drill down to specific information.  For example by clicking on a specific PSC Code you will only see contracts for that PSC Code.
Advanced Search
To conduct an Advanced Search

1. Click on the Advanced Search button [image: image186.png]" Advanced Search
Advanced Search

__Advanced Search
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2 You can select to conduct a search from an existing search or you can choose to conduct a new search.

3 Click on the Add button. Click in the dropdown box and make a selection.  When making a selection from the drop down list of field names you may access the data dictionary which will provide you with a description of acceptable values to enter in the search criteria Like box. Use this link to access the data dictionary http://www.fpdsng.com/downloads/FPDSNG_DataDictionary.pdf to view the field descriptions.
4 Enter a value in the Like box.
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5 Click on [image: image189.png]
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Exercise:  Wrap-up!  Create a new Ad-hoc Report include all Functionality
1) From the Home Page Select Ad-hoc reports.

2) Select your [image: image191.png][_1Personal Folder



.

3) Select [image: image192.png]New Folder



 to create a new Folder for the new report.
4) Select the [image: image193.png]


 button to create a new report.

5) From the Create Report screen Select Section 1 and Add Metrics.
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6) Select Section 2 and Add Attributes.
7) Select Section 3 and Add Filters, add an Attribute filter with a restricted prompt, and then add a Metric Filter with a prompt.
8) Select Section 4 and drag an Attribute to the Section Heading, rearrange the columns.  Click on [image: image195.png]Sorting



 and Sort your report with nested Sorting.  Click on [image: image196.png]Formatting



 and make any desired changes.  Click on [image: image197.png]


 and Add a Calculation to your report.

9) Select [image: image198.png]


 the report.
10) Select [image: image199.png]


 the report.
11) Select [image: image200.png]Display Report



 to see the results.
12) Select [image: image201.png]Chars



 to create a Chart for the report. Select Show More Options and increase the size of your chart or make any other adjustments and save your report.
13) Select [image: image202.png]Export



 to export the report to Excel.

14) Select a Metric for highlighting Select [image: image203.png]Highlighting



 to create a Highlighting rule for the report.  . Give the rule a name and enter values in all four of the numeric value boxes.
15) Select [image: image204.png]Send.



 to email the report.  Do not send the email.

16) Select an Attribute for drilling Select [image: image205.png]


 to drill into the report and add an Attribute value. Create a second drill path.  Return to your Original Table.
17) Select [image: image206.png]Edit



 and make any desired changes to the report.  For example add or delete an Attribute or add or modify an Attribute or Metric filter.

18) Select [image: image207.png]Save |



, then [image: image208.png]


 and then, [image: image209.png]Display Report.




19) Select [image: image210.png]~ Close




20) Congratulations! [image: image211.png]



Rows are sorted secondary on these values





Rows are first sorted on these values 








